const regex = new RegExp('^hostname\\s*(.*?)(?:-[ps])?$', 'gmi')
const str = `terminal width 120
hostname IGN-HSHST-HSH-01-P
domain-name sample.com
hostname ign-hshst-hsh-01-p
hostname ign-hshst-hsh-02-p
hostname ign-hshst-hsd-10
hostname ign-hshst-hsh-01-S
hostname ign-hshst-hsd-11
hostname ign-hshst-hsh-02-s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}