#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(€)(\w*)[.]?(\w*)"
Local $sString = "€11.99" & @CRLF & _
"" & @CRLF & _
"€99"
Local $sSubst = "\2,\3\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)