import Foundation
let pattern = #"(€)(\w*)[.]?(\w*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
€11.99
€99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2,\3\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)