const regex = /(€)(\w*)[.]?(\w*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(€)(\\w*)[.]?(\\w*)', 'g')
const str = `€11.99
€99`;
const subst = `\2,\3\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);