$re = '/(€)(\w*)[.]?(\w*)/';
$str = '€11.99
€99';
$subst = "\2,\3\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;