using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(€)(\w*)[.]?(\w*)";
string substitution = @"\2,\3\1";
string input = @"€11.99
€99";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}