# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\/\w]+)/$1\//gm;t' <<< "/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
"