re = /^([\/\w]+)/m
str = '/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
'
subst = '$1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result