// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([/\w]+)").unwrap();
let string = "/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
";
let substitution = "$1/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}