using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([/\w]+)";
string substitution = @"$1/";
string input = @"/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}