use strict;
my $str = '/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
';
my $regex = qr~^([/\w]+)~mp;
my $subst = '$1/';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";