#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([/\w]+)"
Local $sString = "/news" & @CRLF & _
"/news?param1=value1" & @CRLF & _
"/news#anchor?param1=value1" & @CRLF & _
"" & @CRLF & _
"/some/news" & @CRLF & _
"/some/news?param1=value1" & @CRLF & _
"/some/news#anchor?param1=value1" & @CRLF & _
""
Local $sSubst = "$1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)