package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([/\w]+)`)
var str = `/news
/news?param1=value1
/news#anchor?param1=value1
/some/news
/some/news?param1=value1
/some/news#anchor?param1=value1
`
var substitution = "$1/"
fmt.Println(re.ReplaceAllString(str, substitution))
}