using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)(""(.*?)""|[^--]\S*)?";
string input = @" --opt1--postfix ""quoted value1"" --opt2 value2 -single-dash--opt3 value3 --connstr ""Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd"" -opt4 -opt5 ""value5""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}