package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?`)
var str = ` --opt1--postfix "quoted value1" --opt2 value2 -single-dash--opt3 value3 --connstr "Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd" -opt4 -opt5 "value5"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}