import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^|\\s]*?(--|-))(.+?)(?:\\s+|$)(\"(.*?)\"|[^--]\\S*)?";
final String string = " --opt1--postfix \"quoted value1\" --opt2 value2 -single-dash--opt3 value3 --connstr \"Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd\" -opt4 -opt5 \"value5\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}