import Foundation
let pattern = #"(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" --opt1--postfix "quoted value1" --opt2 value2 -single-dash--opt3 value3 --connstr "Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd" -opt4 -opt5 "value5""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)