// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?"#).unwrap();
let string = " --opt1--postfix \"quoted value1\" --opt2 value2 -single-dash--opt3 value3 --connstr \"Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd\" -opt4 -opt5 \"value5\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}