re = /(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?/m
str = ' --opt1--postfix "quoted value1" --opt2 value2 -single-dash--opt3 value3 --connstr "Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd" -opt4 -opt5 "value5"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end