const regex = /(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^|\\s]*?(--|-))(.+?)(?:\\s+|$)("(.*?)"|[^--]\\S*)?', 'gm')
const str = ` --opt1--postfix "quoted value1" --opt2 value2 -single-dash--opt3 value3 --connstr "Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd" -opt4 -opt5 "value5"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}