$re = '/(?:[^|\s]*?(--|-))(.+?)(?:\s+|$)("(.*?)"|[^--]\S*)?/m';
$str = ' --opt1--postfix "quoted value1" --opt2 value2 -single-dash--opt3 value3 --connstr "Driver={SQL Server};Server=test-svr;Database=test_db;UID=sa;PWD=pwd" -opt4 -opt5 "value5"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);