using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(string@)([a-zA-ZÀ-ž]|\\[0-9]{3})+";
string input = @"string@řetězec\032s\032lomítkem\032\092\032a\010novým\035řádkem
string@\032<not-tag/>\032";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}