// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(string@)([a-zA-ZÀ-ž]|\\[0-9]{3})+").unwrap();
let string = "string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem
string@\\032<not-tag/>\\032";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}