const regex = /(string@)([a-zA-ZÀ-ž]|\\[0-9]{3})+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(string@)([a-zA-ZÀ-ž]|\\\\[0-9]{3})+', 'gu')
const str = `string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem
string@\\032<not-tag/>\\032`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}