$re = '/(string@)([a-zA-ZÀ-ž]|\\\\[0-9]{3})+/u';
$str = 'string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem
string@\\032<not-tag/>\\032';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);