use strict;
my $str = 'string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem
string@\\032<not-tag/>\\032';
my $regex = qr/(string@)([a-zA-ZÀ-ž]|\\[0-9]{3})+/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}