import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(string@)([a-zA-ZÀ-ž]|\\\\[0-9]{3})+";
final String string = "string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem\n\n"
+ "string@\\032<not-tag/>\\032";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}