re = /(string@)([a-zA-ZÀ-ž]|\\[0-9]{3})+/
str = 'string@řetězec\\032s\\032lomítkem\\032\\092\\032a\\010novým\\035řádkem
string@\\032<not-tag/>\\032'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end