# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^```\h*(\S+)/<!-- language: lang-\1 -->\n/g;t' <<< "Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line"