#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^```\h*(\S+)"
Local $sString = "Do not change this line" & @CRLF & _
"" & @CRLF & _
"```markdown" & @CRLF & _
" Sasha great!" & @CRLF & _
" Sasha nice!" & @CRLF & _
" She is beautiful, surprise!" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"```markdown" & @CRLF & _
" Sasha great!" & @CRLF & _
" Sasha nice!" & @CRLF & _
" She is beautiful, surprise!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"```markdown" & @CRLF & _
" Sasha great!" & @CRLF & _
" Sasha nice!" & @CRLF & _
" She is beautiful, surprise!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Do not change this line" & @CRLF & _
"" & @CRLF & _
"```markdown" & @CRLF & _
" Sasha great!" & @CRLF & _
" Sasha nice!" & @CRLF & _
" She is beautiful, surprise!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Do not change this line"
Local $sSubst = "<!-- language: lang-\1 -->\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)