re = /(?m)^```\h*(\S+)/
str = 'Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line'
subst = '<!-- language: lang-\\1 -->\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result