use strict;
my $str = 'Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line';
my $regex = qr@(?m)^```\h*(\S+)@p;
my $subst = '<!-- language: lang-\\1 -->\\n';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";