import Foundation
let pattern = #"(?m)^```\h*(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<!-- language: lang-\1 -->\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)