$re = '@(?m)^```\h*(\S+)@';
$str = 'Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line';
$subst = "<!-- language: lang-\1 -->\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;