package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^```\h*(\S+)`)
var str = `Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line`
var substitution = "<!-- language: lang-\1 -->\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}