# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])/ /gmu;t' <<< "#greenऔर
<सेमीकोलन>
actionएक्शनmysql
admin2को
सेमीकोलन>"