import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[अ-ह\\p{M}])(?=[^अ-ह\\p{M}\\n])|(?<=[^अ-ह\\p{M}\\n])(?=[अ-ह])";
final String string = "#greenऔर\n"
+ "<सेमीकोलन>\n"
+ "actionएक्शनmysql\n"
+ "admin2को\n"
+ "सेमीकोलन>";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}