const regex = /(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[अ-ह\\p{M}])(?=[^अ-ह\\p{M}\\n])|(?<=[^अ-ह\\p{M}\\n])(?=[अ-ह])', 'gmu')
const str = `#greenऔर
<सेमीकोलन>
actionएक्शनmysql
admin2को
सेमीकोलन>`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);