import re
regex = re.compile(r"(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])", flags=re.MULTILINE | re.UNICODE)
test_str = ("#greenऔर\n"
"<सेमीकोलन>\n"
"actionएक्शनmysql\n"
"admin2को\n"
"सेमीकोलन>")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)