import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#greenऔर
<सेमीकोलन>
actionएक्शनmysql
admin2को
सेमीकोलन>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)