re = /(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])/m
str = '#greenऔर
<सेमीकोलन>
actionएक्शनmysql
admin2को
सेमीकोलन>'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result