$re = '/(?<=[अ-ह\p{M}])(?=[^अ-ह\p{M}\n])|(?<=[^अ-ह\p{M}\n])(?=[अ-ह])/mu';
$str = '#greenऔर
<सेमीकोलन>
actionएक्शनmysql
admin2को
सेमीकोलन>';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;