# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=")\t+(?=.+")//gm;t' <<< "_record_number record_id id_testing Notes IntakeComplete
111 6 5 \" We will not be testing because of covid 19\" 1
222 6 5 \" We will not be \"testing because of covid 19\" 1
333 6 5 \" We will not be \"testing\" because of covid 19\" 1"