const regex = /(?<=")\t+(?=.+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=")\\t+(?=.+")', 'gm')
const str = `_record_number record_id id_testing Notes IntakeComplete
111 6 5 " We will not be testing because of covid 19" 1
222 6 5 " We will not be "testing because of covid 19" 1
333 6 5 " We will not be "testing" because of covid 19" 1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);