import re
regex = re.compile(r"(?<=\")\t+(?=.+\")", flags=re.MULTILINE)
test_str = ("_record_number record_id id_testing Notes IntakeComplete\n"
"111 6 5 \" We will not be testing because of covid 19\" 1\n"
"222 6 5 \" We will not be \"testing because of covid 19\" 1\n"
"333 6 5 \" We will not be \"testing\" because of covid 19\" 1")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)