re = /(?<=")\t+(?=.+")/m
str = '_record_number record_id id_testing Notes IntakeComplete
111 6 5 " We will not be testing because of covid 19" 1
222 6 5 " We will not be "testing because of covid 19" 1
333 6 5 " We will not be "testing" because of covid 19" 1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result