# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S)\r?\n(\S)/$1 $2/gm;t' <<< "Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль"