use strict;
my $str = 'Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль';
my $regex = qr/(\S)\r?\n(\S)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";