// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S)\r?\n(\S)").unwrap();
let string = "Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}