import Foundation
let pattern = #"(\S)\r?\n(\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Сайт.com
логин:пароль
логин:пароль
Другойсайт.com
логин:пароль
логин:пароль
логин:пароль
логин:пароль
Ещёодинсайт.com
логин:пароль
логин:пароль
логин:пароль
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)